Important update. From August 1, 2014 MetaTrader 4 desktop terminals older than build 600 will be no longer supported.

Announcement from 23/06/2014

From August 1 2014 Metaquotes stops supporting MetaTrader 4 desktop terminals older than build 600, therefore to make the transition as smooth as possible we strongly advise you to upgrade your MetaTrader 4 platform to the latest build well ahead of that date.

Up-date your terminal now and discover the new features without waiting for August 1.

Please note that some older news announcements may now be out of date and not currently accurate.

← Back to Company News

 

Interested in Forex trading?
Make FXChoice your choice today.
Thousands of traders already have!