MetaTrader 4 desktop clients older than build 500 no longer supported

Announcement from 06/08/2013

As we have already announced via email, from August 1, 2013 MetaTrader 4 desktop client terminals older than build 500 will be no longer supported. This limitation does not apply to the mobile terminals.

In this regard, we strongly recommend all our clients to install the updates and encourage traders to update their trading terminals to build 509 as soon as possible.

Please note that some older news announcements may now be out of date and not currently accurate.

← Back to Company News

 

Interested in Forex trading?
Make FXChoice your choice today.
Thousands of traders already have!